EdgeSight 5.0 and 5.1 will stop functioning

As of 2010-03-25 (March 25th, 2010), EdgeSight 5.0 and 5.1 (all service packs) will stop functioning!

I recently was involved in upgrading an EdgeSight solution to version 5.2. During this process I did some research to be on top of things if problems should arise. The upgrade went very well, but I did find a very interesting CTX-article, about the upcoming expiration of the certificate used by earlier releases of EdgeSight.

The EdgeSight software is digitally signed with a trusted certificate, and it turns out that EdgeSight version 5.0  and 5.1 have a known issue, where the trusted certificate will expire on March 25, 2010. After that date payloads will not be uploaded and many of the EdgeSight components will not work properly resulting in different errors.

Customers will receive the following error message for payload uploads:

“Archive load error: The archive ‘/edgesight/app/suser/ZRemoteLib.zpd#12!lsync.htm’ is not appropriately signed.  The system cannot find the file specified.”

Customers running EdgeSight 5.0 and 5.1 must update both server and agent components to EdgeSight 5.2 or later. Customers running EdgeSight 5.2 do not need to take action.

Install the server component first, then apply the agent installation to all devices. Older agents can report successfully to a newer EdgeSight server.

Please be aware that the 5.2 agents cannot report to older versions of EdgeSight.

For more information check out CTX124013: http://support.citrix.com/article/ctx124013

Jacob Berg